Chevy C10 Truck Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello, I’ve been working at an issue with my 1980 Bonanza c10, and I’ve tried everything I can to my knowledge. Here’s the issue… My indicator switch went out a week or two ago I thought no big deal I’ll replace it. I got the part a few days later and tore the steering wheel off and installed the new switch. I plug in the switch and go to test it out. When I would indicate right in the truck, the rear indicator would indicate right as it should. But when I indicated left it also indicated right on the back of the truck. when I hit my hazards it only worked on the right side and the same goes with my markers and brake lights. I checked every wire in the cluster with a multimeter and both the right and left indicator wires (light blue and dark blue) had power how they should according to the direction I would indicate. I decided to check the wiring in the back and clean the ground, but there was only a ground on the left side and when I would attach a wire to ground the right side none of the lights would work. However when I would switch the ground from left to right with only one on at a time, the one side that had the ground would work and the other wouldn’t. I’m kinda at a loss at this point so any advice or ideas would be very helpful. I seems like quite a mess so I appreciate you reading and hopefully responding. Thanks!
 

·
Super Moderator
1964 C-10-383 stroker-12 bolt posi & 1977 shortbox- nasty 454- 12 bolt posi 3:73
Joined
·
803 Posts
What did it do before? Maybe you got a bad switch? Are you using incandescent bulbs or leds? Check this recent post with link to some good info..

 
1 - 2 of 2 Posts
Top