Chevy C10 Truck Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Hi - first time post . I have a 69 c10 longbox that I'm using as my daily driver. just purchased the ride and am fixing a few of the bugs. one that is annoying is the heater fan only runs on low - other wise it just shuts off. Living in South Dakota a heater that blows in very needed. I have replaced the fan switch - the fan relay and check my 12v supply. I've taken the relay apart and manually operated the switch inside and it works perfectly. -- so apperntly i'm missing the 12v supply to the coil inside the relay.. where does that orginate from -- or is there something else that i'm missing. Please help !!
 

·
Registered
Joined
·
6,754 Posts
lonewolfe1 sign0016 To C10 Trucks Your heater switch has wires that go into the heater houseing Where they plug in is the resistor for the speed control. There should be a couple screws holding it in. My guess is the resistor is shot Your parts store or LMCtruck should be able to get you one. Enjoy your stay and I hope this helps
anim_25
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
thanks for your help . -- I looked this am for said resistorand am having a tough time locating it. My truck has AC and I have the glove box out, following the wiring I still cannot locate this resistor. Any advice to help the search would be great. Thanx..Is it inside the heater box ?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 · (Edited)
FOUND IT !!! thank you . and yes its broken. Our parts stores here did not have such a gem so it is ordered. Once again thanks for the help. The pix was a big help -- but mine was inside the heater box under the dash, still very easy to get to once I knew what to look for. LMC trucks had just what I was needing. Thanks again - I'm sure I will be contacting you again..
 
1 - 6 of 6 Posts
Top