Chevy C10 Truck Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hi everyone, new to the forum.
I have a 66 c 10 fleetside, and the issue I'm having is the rear turn signals work opposite of each other, and the brake lights don't work. I was wondering where all of the grounds are on these trucks and what else to look for
 

·
Registered
Joined
·
6,754 Posts
Brandon sign0016 To C10 Truck There should be a ground near the rear of the bed/frame Going from body to frame Check at light sockets too. Be sure the battery is grounded good to the frame and cab. I use star washers for all grounds anim_25 and post some pictures of your ride
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
i had pulled the center harness out of it earlier. the piece that goes from the firewall back to the taillight assembly. I didnt come across any wires attached to the frame or anything from the harness that indicates that there was even a wire there at one time.
 

·
Administrator
Joined
·
3,966 Posts
Put new grounds from the taillight bucket to the frame to insure good grounds, and although you or should I say many people find out these trucks were poorly grounded, three more ground straps, engine to frame, frame to cab, cab back to engine, you`ll quickly realize how much brighter your lights work and the engine cranks over much quicker. mine are made from double 00 welding cable with soldered eyelets, tru bolts with stainless starr washers to bite into the metal.. this way we can rule out bad grounds as the culprit...
The rear part of the harness is a plug in just at the rear left side, ensure that it is plug in correctly, its supposed to plug in one way, but you never know...
 
1 - 5 of 5 Posts
Top