Chevy C10 Truck Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
108 Posts
Discussion Starter · #1 ·
1965 Chevrolet C10

My blinkers stopped working suddenly. Hmmn..

The hazards will flash on the driver side, but not the passenger side.

My flasher clicker thingy majingy(I always forget what the part is called) on the fuse panel sounds like it clicks once and stops... maybe it is just worn out and went ker-plunk. I'm going to replace it later today.

I also checked for voltage at the spot on the fuse panel where the blinker clicker thing plugs in and getting almsot 12v on one side so maybe it's just the clicker.

However, if it isn't, anything else I should check out?

-W
 

·
Registered
Joined
·
108 Posts
Discussion Starter · #5 ·
ok, so I checked each individual bulb for continuity, all is well.

I was checking something under the dash and I noticed part of the wiring harness was unplugged.

Hmnn... how did that happen and where does it go?

Oh. It goes to the steering column.

DOH.

:D

I plugged in back up and all is well with the world.

I zip tied it together so it wouldn't slide apart again.

I supposed I unplugged it somehow while my big hands were routing wires and things around under the dash.

Thanks for all of the suggestions folks and happy wrenching.



-W
 

·
Registered
Joined
·
108 Posts
Discussion Starter · #7 ·
It was this plug right here... somehow or another it was completely unplugged, I suppose because of my rooting around all under the dash tracing wires and double checking things.

I zip tied it together so that it would not come apart accidentally again.

bowtieb

-W
 

Attachments

1 - 7 of 7 Posts
Top